Jump to content


Photo

Another error in my route


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 ctempire

ctempire

    Motorman

  • Route Beta
  • PipPipPip
  • 96 posts

Posted 05 September 2009 - 05:05 PM

A few days ago, I tried making longer curves around Blythe at my Desert Route, but when I restart RE, it crashes. A small fix I revealed is that when I remove a track section by modifying a world(.w) file, I t fixes but only to the tile of the .w file. Going further without modifications on tiles leads to the crash. Is there's an option to fix it in Route Riter?

#2 SAR704

SAR704

    Dispatcher

  • Valued Customer
  • PipPipPipPip
  • 579 posts

Posted 05 September 2009 - 06:47 PM

You can't remove a track section by just editing the W file unless you plan to a TDB rebuild afterwards.

I think what you mean to say is that the tile where you edited the W file still loads. When you run to an adjacent tile in the RE it crashes?

Are there any signals or signal nodes in the route, or interactives? I tend to recall a fictional route from years ago which would crash if you modified any of the track. I never figured out what was causing this problem. It's possible you're experiencing the same scenario.

Try doing a TDB rebuild. Test the route from start to finish with the supercharged dash 9 or something else that can go at lightning speed. Otherwise you'll need to go back to the last good backup. You're probably best off not editing the track with interactives and signals in.

#3 ctempire

ctempire

    Motorman

  • Route Beta
  • PipPipPip
  • 96 posts

Posted 05 September 2009 - 08:21 PM

QUOTE(SAR704 @ Sep 5 2009, 6:28 PM) View Post

You can't remove a track section by just editing the W file unless you plan to a TDB rebuild afterwards.

I think what you mean to say is that the tile where you edited the W file still loads. When you run to an adjacent tile in the RE it crashes?

Are there any signals or signal nodes in the route, or interactives? I tend to recall a fictional route from years ago which would crash if you modified any of the track. I never figured out what was causing this problem. It's possible you're experiencing the same scenario.

Try doing a TDB rebuild. Test the route from start to finish with the supercharged dash 9 or something else that can go at lightning speed. Otherwise you'll need to go back to the last good backup. You're probably best off not editing the track with interactives and signals in.

It even crashes when a TBD rebuild is performed. I overwrite the route with my latest working backup.

Okay. Here's what happened;

On the early days of the route, I'm not an experienced route builder. I placed endpt10lfts as curves but later as my knowledge grew, I need to replace them with smoother and bigger curves. I used dynamic track and 2-3 10m track pieces to eliminate a tight curve at Blythe as well changing some track work on the small yard were the station used to be at near the curve. If you still don't understand or so, please reply.