Jump to content


Photo

Need An Assist...


This topic has been archived. This means that you cannot reply to this topic.
42 replies to this topic

#21 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 22 June 2005 - 09:27 PM

I have been playing with the .eng files and the .wag files trying to change coupler types. CE shows them as both automatics after I make the change, but they still don't work. I saw the two coupler set ups, on the engine, the first listed is the bar coupler and then the automatic. The reverse is true with the tenders. Wouldn't I need the automatic first so it would be on the front of the engine? this is very strange.

#22 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 23 June 2005 - 05:24 AM

No. The way they were done in the .eng and .wag files is correct. When setting up .eng files, the coupling between loco and tender is first, the front coupler second. Reverse with the tender. In other words, the rear coupling is the first to be shown. Don't have a clue why this is the case.
If you want to change to automatic couplers, simply eliminate all the statements associated with the bar coupler and allow the auto coupler statements to default for both front and rear (look at the old loco and tender files). If there is not a second set of statements, the sim assumes the values apply to both front and rear.

Bill Hobbs

#23 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 23 June 2005 - 07:09 PM

I have no luck putting the other two modified activities into the sim. I get an error message saying it is for route number 53 and I have 51. It does not allow me to overwrite.

I have eliminated all the bar couplers, but I still can't make the AE save the modified consist. maybe I just have a corrupt download?

Andre if you read this, would I be able to redownload it again to see if it makes any difference?

so close and yet so far!

#24 laming

laming

    Robber Baron

  • V Scale Creations
  • PipPipPipPipPipPipPip
  • 3,524 posts

Posted 23 June 2005 - 08:18 PM

"Andre if you read this, would I be able to redownload it again to see if it makes any difference?"

Sure. Same password.

Andre

#25 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 23 June 2005 - 08:51 PM

Have you checked to see if the .con file is still Readonly?

Bill Hobbs

#26 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 24 June 2005 - 07:50 PM

hmmm, the .con files are all read only. I changed one to read write and replaced the equipment only to be told the sim can't find the cab view (and the folder does exist with the alias file) and then it crashes. incrimental progress at best. Why is it I am the only one having this issue? very frustrating.

#27 TomW

TomW

    Dispatcher

  • Members
  • PipPipPipPip
  • 516 posts

Posted 25 June 2005 - 09:07 AM

I'm not sure why you're having trouble, but when you mentioned the Cabview message.
I recalled that every loco in the NAPack (except maybe #2) uses the original StL&NA ("default") cabview
that's in the NARequired folder.

Suggest you see if that has been removed or changed?

First, I'm NOT an MSTS expert, like some of the "wizards" that post here.
However, having aliased cabviews and sounds in other routes and on other equipment,
I've noted that Andre organizes his files a bit differently.
Therefore, I don't hack his files like I will other routes.

Maybe this is an obvious suggestion, but a completely clean reinstall of the StL&NA,
followed by the NA Pack might be your final resort?

#28 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 25 June 2005 - 05:48 PM

Let me hazard a guess as to what might have happened. I am assuming that you are not making other changes that you are not mentioning. If the loco you added is one that you changed the coupler settings on, you may well have missed one or more closing bracket(s) associated with the coupler statements. The sim may have continued to try and read in the .eng file until it came to what it considered a critical error, then quit.
One way to isolate this from your general problems in changing the existing .con files would be to simply create a new .con file with just the loco and tender combination you are working with. If that too doesn't work, but other unaltered consists can be started ok in Explore Mode, then it is something you have done to that .eng file.
The first commandment of programming is "Thou shalt take backups before making changes". When working on .eng files, I keep a backup of the original in a folder away from the TrainSim folder, so I can always start over again.
If you want, you can post the offending .eng file online here and I'll look at it next time I'm online
Bill Hobbs

#29 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 26 June 2005 - 07:51 AM

I have done a complete reinstall of the route and the NA pack. Same results. Here is an engine and tender from the hard drive...no changes were made on these.

SIMISA@@@@@@@@@@JINX0D0t______

Wagon ( StLNA_260_7
comment( Baldwin shortline 2-6-0 )
Type ( Engine )
WagonShape ( StLNA_260_7.s )
Size ( 3.123m 3.79m 9.997m )
CentreOfGravity ( 0m 1.7m 0m )
Centre ( 0m 0m 0m )
Mass ( 61t )
InertiaTensor ( Box(3.1m 3.9m 9.997m) )
Coupling (
Type ( Bar )
Spring (
Stiffness ( 1.2e6N/m 4.8e6N/m )
Damping ( 1.2e6N/m/s 3.3e6N/m/s )
Break ( 1.8e7N 1.8e7N )
r0 ( 1cm 40cm )
)
CouplingHasRigidConnection ( 1 )
Velocity ( 0.1m/s )
CouplingUniqueType (StLNA)
)
Coupling (
Type ( Automatic )
Spring (
Stiffness ( 1.2e6N/m 4.8e6N/m )
Damping ( 1.2e6N/m/s 3.3e6N/m/s )
Break ( 1.8e7N 1.8e7N )
r0 ( 10cm 40cm )
)
Velocity ( -0.1m/s )
)

Adheasion ( 0.3 0.76 .67 0.0 )
DerailRailHeight ( 10cm )
DerailRailForce ( 2.5*67.5t )
DerailBufferForce ( 400kN )
WheelRadius ( 0.3302m )
NumWheels ( 3 )
Friction (
4437.2N/m/s 0 1mph 9.481N/m/s 1.8
5.1N/rad/s 1 -1rad/s 0 1
)

BrakeEquipmentType( "Triple_valve, Auxilary_reservoir, Emergency brake reservoir" )
BrakeSystemType( "Air_single_pipe" )
MaxBrakeForce( 26kN )
EmergencyBrakeResMaxPressure( 70 )

TripleValveRatio( 2.5 )
MaxReleaseRate( 2.5 )
MaxApplicationRate( 2 )
MaxAuxilaryChargingRate( 1 )
EmergencyResChargingRate ( 1 )
BrakeCylinderPressureForMaxBrakeBrakeForce( 46 )

Sound ( "..\\..\\NA_Required\\SteamSoundsOrgUk\\GWR-Manor-Ext-StLNA.sms" )

Lights ( 2
Light (
comment( Sphere of light )
Type ( 1 )
Conditions (
Headlight ( 3 )
Unit ( 2 )
)
Cycle ( 0 )
FadeIn ( 0.5 )
FadeOut ( 0.5 )
States ( 1
State (
Duration ( 0.0 )
LightColour ( ffffff99 )
Position ( 0 3.497 3.814 )
Transition ( 0 )
Radius ( 80.0 )
Angle ( 25.0 )

)
)
)
Light (
comment( Head light )
Type ( 0 )
Conditions (
Headlight ( 3 )
Unit ( 2 )
)
FadeIn ( 0.5 )
FadeOut ( 0.5 )
Cycle ( 0 )
States ( 1
State (
Duration ( 0.0 )
LightColour ( ffffff99 )
Position ( 0 3.497 3.814 )
Azimuth ( 0.0 -5.0 5.0 )
Transition ( 0 )
Radius ( 0.7 )
Elevation ( 0 0 0 )
)
)
)
)

FreightAnim( StLNA_260_7_crew.s 1 1 )

)


Engine ( StLNA_260_7
comment( Baldwin shortline 2-6-0 )
Effects
(
SteamSpecialEffects
(
comment
(
the format of these little blocks is as follow:

offset.x offset.y offset.z
normal.x normal.y normal.z
width in metres

defining the offset from the shape pivot point
where steam / smoke should appear, the direction
it should go and the width of the nozzle
)

WhistleFX
(
0.0 4.1 -1.2513
0 1 0
0.12
)

SafetyValvesFX
(
0 4.1 -1.08
0 1 0
0.2
)

StackFX
(
0 4.61 2.712
0 1 0
0.2
)

DrainpipeFX
(
-1.5 1.258 -3.886
-0.4 -1 -0.2
0.05
)

CylindersFX
(
-1.06 0.28 2.3911
-1 0 0
0.1
)

CylindersFX
(
1.06 0.28 2.3911
1 0 0
0.1
)
)
)

Wagon ( StLNA_260_7 )
IsTenderRequired( 1 )
Type ( Steam )
MaxPower ( 700kW )
MaxForce ( 25450lbf )
MaxVelocity ( 30mph )
WheelRadius ( 0.7112m )
Sanding ( 1e15mph )
NumWheels ( 3 )
BoilerLength ( 5.5m )
BoilerVolume ( 160 )
BoilerEffectivity ( 1 )
DraftingEffect ( 1.3 )
BoilerResponsiveness ( 1 )
CoalBurnage ( 3.5lb/hp/h )
MaxBoilerOutput ( 22300lb/h )
NumCylinders ( 2 )
CylinderStroke ( 26in )
CylinderDiameter ( 19in )
CylinderVolume ( 17 )
CylinderEffectivity ( 1.75 )
ExhaustLimit ( 18300lb/h )
PrimingFactor ( 1 )
SteamMinPrimingLevel ( 1 )
BlastExponent ( 0.5 )
MaxBoilerPressure ( 180psi )
MaxFireMass ( 1000lb )
IdealFireMass ( 640lb )
MaxWaterMass ( 2000lb )
SafetyValvesSteamUsage ( 16000lb/h )
ShovelCoalMass ( 1lb )
SmokeCombustion ( 1 )
MaxTenderCoalMass ( 16000lb )
MaxTenderWaterMass ( 41700lb )

SuperHeater ( 1 )
SteamSmokeUnitsPerPoundOfFuel( 3.5 )
SteamMaxSmokeUnitsReleaseRate( 10 )
MaxSteamHeatingPressure( 80 )
SafetyValvePressureDifference( 5 )
SteamGaugeGlassHeight( 10 )
SteamFiremanMaxPossibleFiringRate( 5000 )

BasicSteamUsage ( 400lb/h )
BasicCoalUsage ( 320lb/h )

comment(0 for live steam, 1 for exhaust steam)
InjectorTypes( 0 1 )
InjectorSizes ( 12mm 12mm )
Injector1WaterValveVariance( .8 )
Injector2WaterValveVariance( .8 )
InjectorLimits1 ( 35psi 0.2 1 )
InjectorLimits2 ( 35psi 0.2 1 )
CylinderCocksPowerEfficiency ( 0.85 )

SteamCylinderCocksOperation( Manual )
SteamSmallestCutoff( 0.2 )
NumberOfDamperSteps( 4 )

AirBrakesAirCompressorPowerRating( 1 )
AirBrakesMainMinResAirPressure( 0 )
AirBrakesMainMaxAirPressure( 100 )
AirBrakesMainResVolume( 15 )
AirBrakesCompressorRestartPressure( 95 )
AirBrakesAirUsedPerPoundsOfBrakePipePressure( 1 )
AirBrakesHasLowPressureTest( 1 )

TrainBrakesControllorMinPressureReduction( 6 )
TrainBrakesControllerMaxReleaseRate( 1 )
TrainBrakesControllerMaxApplicationRate( 2 )
TrainBrakesControllerEmergencyApplicationRate( 5 )
TrainBrakesControllerMinSystemPressure( 0 )
TrainBrakesControllerMaxSystemPressure( 70 )
TrainBrakesControllerEmergencyBrakeTimePenalty( 60 )
TrainBrakesControllerFullServicePressureDrop( 20 )

EngineBrakesControllorMinPressureReduction( 6 )
EngineBrakesControllerHasProportionalBrake( 1 )
EngineBrakesProportionalBrakeLag( 0.9 )
EngineBrakesControllerMaxApplicationRate( 2 )
EngineBrakesControllerMaxReleaseRate( 5 )
EngineBrakesControllerEmergencyApplicationRate( 5 )
EngineBrakesControllerMinSystemPressure( 0 )
EngineBrakesControllerMaxSystemPressure( 70 )
EngineBrakesControllerEmergencyBrakeTimePenalty( 60 )
EngineBrakesControllerFullServicePressureDrop( 20 )
EngineBrakesControllerDirectControlExponent( 1 )

BrakesEngineBrakeType( "Air_single_pipe" )
BrakesTrainBrakeType( "Air_single_pipe" )
BrakesEngineControllers( "Hand,Train,Independent" )

RegulatorValveType( Single_port )
RegulatorMainValveExponent( 1 )

SteamBlowerEffectExponent( 1.1 )
SteamBlowerEfficiencyExponent( 1.1 )
SteamBlowerMaxSteamUsageRate( 1000 ) comment( lbs/h )
SteamBlowerMaxProportionOfBlastEffect( 0.25 )

CabView ( alias.cvf )
HeadOut ( 1.65 3.077 -4.875 )

EngineControllers (
comment( Engine controls )

Regulator ( 0 1 0.1 0
NumNotches( 0 )
)
Cutoff ( -0.65 0.8 0.05 0
NumNotches( 24
Notch(-.65 0 )
Notch(-.60 0 )
Notch(-.55 0 )
Notch(-.50 0 )
Notch(-.45 0 )
Notch(-.40 0 )
Notch(-.35 0 )
Notch(-.30 0 )
Notch(-.25 0 )
Notch(-.20 0 )
Notch(0 0 )
Notch(.2 0 )
Notch(.25 0 )
Notch(.30 0 )
Notch(.35 0 )
Notch(.40 0 )
Notch(.45 0 )
Notch(.5 0 )
Notch(.55 0 )
Notch(.60 0 )
Notch(.65 0 )
Notch(.70 0 )
Notch(.75 0 )
Notch(.8 0 ))
)
Brake_Train ( 0 1 0.1 .65
NumNotches( 6
Notch(0 0 TrainBrakesControllerReleaseStart )
Notch(0.2 0 TrainBrakesControllerRunningStart )
Notch(0.4 0 TrainBrakesControllerSelfLapStart )
Notch(0.5 1 TrainBrakesControllerApplyStart )
Notch(0.9 0 TrainBrakesControllerFullServiceStart )
Notch(1.0 0 TrainBrakesControllerEmergencyStart )
)
)
Brake_Engine ( 0 1 0.1 1
NumNotches( 4
Notch(0 1 EngineBrakesControllerReleaseStart )
Notch(0.2 0 EngineBrakesControllerRunningStart )
Notch (.3 0 EngineBrakesControllerApplyStart)
Notch(.5 1 EngineBrakesControllerFullServiceStart )
)
)
FireDoor ( 0 1 1 0
NumNotches( 0 ))
Sanding( 0 1 0 )
Blower ( 0 1 0.05 0.1
NumNotches( 0 )
)
HeatingTap ( 0 1 0.025 0
NumNotches( 0 )
)
Shovel ( 0 1 0.1 0
NumNotches( 0 )
)
DampersFront ( 0 1 0.1 1
NumNotches( 0 )
)
DampersBack ( 0 1 0.1 0
NumNotches( 0 )
)
Injector1Steam ( 0 1 0 )
Injector2Steam ( 0 1 0 )
Injector1Water ( 0 1 0.1 0
NumNotches( 0 )
)
Injector2Water ( 0 1 0.1 0
NumNotches( 0 )
)
CylinderCocks ( 0 1 0 )
Whistle ( 0 1 0 )
BellToggle ( 0 1 0 )
SmallEjectorOrCompressor( 0 1 1 )
Headlights( 0 1 0 )
)

comment(fire temp, fire mass, water mass, boiler pressure, water level,
tender_water_mass, tender_coal_mass, smoke_quantity,
fire_condition, coal quality )

EngineVariables( 950 620lb 1600lb 170 1 41700lb 16000lb 200 1 1 )

Sound ( "..\\..\\NA_Required\\SteamSoundsOrgUk\\GWR-Manor-Int-100b-StLNA.sms" )
Name ( "StLNA 7 DLW" )
Description (
"text goes here"+
"Brakes: air\n\n"
)
EngineOperatingProcedures (
"To move forward\n"+
"1. Press the W key several times to move the Reverser to full Forward.\n"+
"2. Press the ; (SEMICOLON) key to release the train brakes.\n"+
"3. Press the D key to increase the Regulator setting.\n"+
"4. As you accelerate, press the S key to slowly reduce the Reverser setting, then adjust the Regulator to maintain the desired speed.\n\n"+
"To slow the train\n"+
"1. Press the A key to move the Regulator to a lower setting.\n"+
"2. Use the brakes to further reduce speed if desired.\n\n"+
"To apply the train brakes\n"+
"1. Press the ' (APOSTROPHE) key to apply the train brakes.\n"+
"2. To hold the brakes at their current setting, lower the brake lever until it's in its middle (Neutral) position, by pressing the ; (SEMICOLON) key.\n\n"+
"To release the train brakes\n"+
"1. Press the ; (SEMICOLON) key to release the train brakes.\n"+
"2. When the brakes are released, raise the brake lever until it's in its middle (Neutral) position, by pressing the ' (APOSTROPHE) key.\n\n"+
"To back up\n"+
"1. Bring your train to a full stop.\n"+
"2. Press the S key several times to move the Reverser to the full Reverse position.\n"+
"4. Press the ; (SEMICOLON) key to release the brakes.\n"+
"5. Slowly advance the regulator (D key).\n\n"+
"To load and unload passengers\n"+
"1. Stop at a station.\n"+
"2. Press the ENTER key.\n"+
"3. Wait for the \"permission to depart\" whistle.\n"+
"TIP: Use the Next Station driving aid (F10) to monitor loading and unloading.\n\n"+
"To couple to a car or locomotive\n"+
"1. Coast into the unit at a very slow speed, about 2 mph.\n"+
"TIP: To use the Coupling view, press the 6 key.\n"+
"2. Press F9 to open the Train Operations window.\n"+
"3. If the icon for the unit you coupled to is red, the handbrake is on. Double-click the car to release the handbrake.\n"+
"4. Close the Train Operations window.\n\n"+
"To uncouple from a car or locomotive\n"+
"1. Press F9 to open the Train Operations window.\n"+
"2. Double-click a unit in the part of the train you want to uncouple from the locomotive, to set the handbrake.\n"+
"3. Double-click the coupler between the units you want to uncouple and the rest of the train.\n"+
"4. Close the Train Operations window.\n\n"+
"Firing commands (Automatic Fireman OFF in Options screen)\n"+
"To add coal to the firebox\n"+
"1. Press the F key to open the Firebox door.\n"+
"2. Press the R key to increase the shoveling rate.\n\n"+
"To stop adding coal to the fire\n"+
"1. Press SHIFT+R to decrease the shoveling rate.\n"+
"2. Press SHIFT+F to close the firebox door.\n\n"+
"To operate the blower\n"+
"1. Press the N key to increase the blower.\n"+
"2. Press SHIFT+N to decrease the blower.\n\n"+
"To operate the dampers\n"+
"1. Press the M key to open the dampers.\n"+
"2. Press SHIFT+M to close the dampers.\n\n"+
"To inject water into the boiler\n"+
"1. Press the I key to turn on the steam to Injector 1.\n"+
"(You can also press the O key to turn on the steam to Injector 2.)\n"+
"2. Press the K key to increase the water flow to Injector 1.\n"+
"(To increase the water flow to Injector 2, press the L key.)\n\n"+
"To stop boiler water injection\n"+
"1. Press the I key to turn off the steam to Injector 1.\n"+
"2. Press the O key to turn off the steam to Injector 2."
)
)



and the tender;

SIMISA@@@@@@@@@@JINX0D0t______

Wagon ( StLNA_260_7t
Type ( Tender )
WagonShape ( StLNA_260_7t.s )
Size ( 2.7m 3.816m 7.325m)
CentreOfGravity ( 0m 1.90m 0m )
Mass ( 35.9t )
InertiaTensor ( Box (2.7m 3.816m 7.325m) )
Coupling (
Type ( Automatic )
Spring (
Stiffness ( 1.2e6N/m 4.8e6N/m )
Damping ( 1.2e6N/m/s 3.3e6N/m/s )
Break ( 1.8e7N 1.8e7N )
r0 ( 10cm 40cm )
)
Velocity ( 0.1m/s )
)
Coupling (
Type ( Bar )
Spring (
Stiffness ( 1.2e6N/m 4.8e6N/m )
Damping ( 1.2e6N/m/s 3.3e6N/m/s )
Break ( 1.8e7N 1.8e7N )
r0 ( 5cm 40cm )
)
CouplingHasRigidConnection (1)
Velocity ( 0.1m/s )
CouplingUniqueType (StLNA)
)

Adheasion ( 0.2 0.4 2 0 )
DerailRailHeight ( 10cm )
DerailRailForce ( 150kN )
DerailBufferForce ( 400kN )
WheelRadius ( 0.4825m )
NumWheels ( 8 )
Friction (
983.8N/m/s -.2 6.0mph 5.104N/m/s 1.586
5.1N/rad/s 1 -1rad/s 0 1
)

BrakeEquipmentType( "Handbrake, Triple_valve, Auxilary_reservoir, Emergency_brake_reservoir" )
BrakeSystemType( "Air_single_pipe" )
MaxBrakeForce( 8kN )

MaxHandbrakeForce( 12kN )
NumberOfHandbrakeLeverSteps( 100 )

TripleValveRatio( 2.5 )
MaxReleaseRate( 0.95 )
MaxApplicationRate( 0.50 )
MaxAuxilaryChargingRate( 1.0 )
EmergencyResCapacity( 3.6 )
EmergencyResChargingRate( 1.0 )
EmergencyBrakeResMaxPressure( 70 )
BrakeCylinderPressureForMaxBrakeBrakeForce( 46 )

IntakePoint ( 0.0 10.0 FuelWater )
IntakePoint ( 0.0 10.0 FuelCoal )

FreightAnim( stlna_260_7_coal.s 0.5 0 )

Name ( "StLNA 7t DLW" )
Sound ( "genfreightwag1.sms" )
)


If there is something wrong with it, it came this way from the download.

Since no one else seems to be having this problem, I am thinking it is something else on my computer.

#30 TomW

TomW

    Dispatcher

  • Members
  • PipPipPipPip
  • 516 posts

Posted 26 June 2005 - 08:50 AM

A complete reload and still no success? mad.gif

OK, just for the record, what are your system specs???

Maybe one the wizards out there will see something wrong.

#31 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 26 June 2005 - 02:40 PM

Now that you have done a reinstall, what does and what does not work? Can you run the original activities as they came? Can you make a consist with this locomotives and tender and load it in Explore mode?

Bill Hobbs

#32 Gixxer86

Gixxer86

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 148 posts

Posted 27 June 2005 - 04:53 PM

Can you run these consists in other routes?

#33 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 27 June 2005 - 07:43 PM

It seems I can indeed run the new stuff in explore mode. I just can't get any of it into an activity. Work across all routes the same way. ok in explore, not for activities.

#34 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 27 June 2005 - 07:56 PM

ok, it now appears I can indeed substitute NAP locomotives for any route EXCEPT St. Louis and NA. so what is different about this route? I was able to put NAP engines into the A&M route, into Canton Suddenly with no problem via route riter. When I try to make a replacement in St.L&NA, no replacements are made. Is there something I can change in the route?

#35 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 27 June 2005 - 07:59 PM

Gixxer86,
Are you asking Sevenbrewer or me? Certainly the consists should run in any route if there is not a problem with something in the .eng files, .wag files, or .con files. Without being able to see what is going on, the only way I can think of to take a guess where the problem is is by trying to eliminate issues one by one. If a simple consist can be made with loco and tender and loaded on one route, it should run on any route. I don't think the route is the source of problems, but the best way to check for sure would be to try a consist of non-StL&NA equipment on that route in Explore mode.
Andre's scheme of putting the cabviews and sound files in his NA_Required folder is not unusual. I've done similar things for a couple of years to avoid wasting disk space with duplicated files. Once you learn how to reference an .ace or .wav file that is not in its standard location, making the conversion is just a matter of going through one's .cvf and .sms files to make the changes.
I don't know how Andre's install proram works. I would expect that it starts by deleting or writing over any older folders with the same names so that one does not get stuck with partial old data. If so, one should be able to run the supplied activities and consists without problem.
Sevenbrewer apparently didn't have problems until he tried to substitute equipment into existing activities by changing consist files. Part of the issue then may have been the inability to save the changed con files. The issues of coupler incompatibility would have shown up in Conbuilder, however, before trying to save and those would have occured if an equipment swap mismatched a loco and tender using the unique bar couplings. What happened from that point on involved making changes to the coupler statements and then the problems with the cabviews apparently started. Missing brackets in the .eng file could have easily caused the initial problem there.
But this is all a guess based on reading the emails.

Bill Hobbs

#36 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 27 June 2005 - 08:56 PM

I did just notice that the StLNA activities are all 'read only' and all other routes are not. I went in and changed all the StLNA activities to not just 'read only'. I thought this might solve the problem, but no dice. I can not replace ANY equipment on the StLNA route even after this change. Activity master still crashes out trying to make a change to StLNA. AE still can't make a change either....again ONLY in StLNA. Is there an update patch for the route I am missing?

Incidently, the CNW gp40's look right at home on the A&M...it looks like most anywhere Wisconsin on that route.

#37 wmghobbs

wmghobbs

    Engineer

  • Members
  • PipPipPip
  • 230 posts

Posted 28 June 2005 - 05:28 AM

Did you change the .con files and the .act files? I don't think the .srv files need to be changed but it might be something to do if nothing else works. As Andre noted, his process of copying to disk changed all the files to read-only.
Before doing anything else, make sure that you can build your own consist using the new equipment using one of the consist builders.

Bill Hobbs

#38 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 28 June 2005 - 08:13 AM

Ok we have progress! I finally was able to replace the engine in an activity via route riter. The activity runs fine. Now for the next trick....why doesn't activity Master even 'see' the equipment? If you can't see it you can't add it to the available equipment file. any thoughts?

#39 Gixxer86

Gixxer86

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 148 posts

Posted 28 June 2005 - 07:10 PM

I was asking Sevenbrewer.

#40 sevenbrewer

sevenbrewer

    Porter

  • Valued Customer
  • PipPip
  • 20 posts

Posted 28 June 2005 - 08:41 PM

yes, I was able to run the consist in another route. It seems I can now subsittute items in route riter but still not in Activity Master. I expect it is a problem with the naming convention used in the NAP. Anyone else used Activity Master without problems?