Jump to content


Scale Rail Question

This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 MojaveYard



  • Valued Customer
  • PipPip
  • 24 posts

Posted 04 December 2011 - 11:18 AM

Have downloaded the FBL and PO&N routes from Train Sim, and in the "Read Me" of the FBL, it requires 3D Trains' Scale Rail V1.7. I may not have have looked close enough, but was unable to locate the specific version of Scale Rail that is asked for in your site's Scale Rail heading. Could you please provide the information I am seeking?

Also, I noticed several other Scale Rail add-ons, particularly the ATSF/SP version. I would like to add this item to my existing MSTS and will purchase/download same if this item can be used. I think I already have the scenery enhancement versions for both Tehachapi and Cajon Pass, so is this addition a separate add-on? Thank you.

#2 Hack


    The Big Kahuna

  • 3DTrains Admin
  • 7,394 posts

Posted 04 December 2011 - 12:47 PM

Try here (v1.77):


The other version of ScaleRail you mentioned (ATSF/SP) is for Railworks, and is not compatible with MSTS or the expansions.