Jump to content


Photo

SR_1Dmy_w_020m.s


This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 02 July 2011 - 11:13 AM

The scale rail section SR_1Dmy_w_020m.s as well as the SR_1Dmy_c_020m.s are causing fits with the routes I have made with these sections. I tried it with tsection.dat 38 & 41 same result. I recently dloaded all the sections of scalerail again due to having to reinstall the os. Not sure at all as to why this is but i started figuring that this was the problem and laid a new section of both and as soon as I clicked anywhere else after laying the sections ET phoned home. Not at all sure how to go about fixing it.

#2 Bananarama

Bananarama

    The Big Kahuna

  • 3DTrains Admin
  • 8,090 posts

Posted 03 July 2011 - 01:04 AM

They're giving you fits, yet you haven't provided any details of the error.

Cheers!
Marc

#3 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 03 July 2011 - 05:06 AM

QUOTE(Hack @ Jul 3 2011, 12:45 AM) View Post

They're giving you fits, yet you haven't provided any details of the error.

Cheers!
Marc

Not much to give. The only error message I get is the Were sorry but we need to close due to a problem. With out the tdb it loads fine so I Assume the problem is not in the shape but rather in its relationship with the tdb. If I try and rebuild the tdb when it gets to where it loads the shape it crashes. It will not load the shape either in game or in the route editor, however in the activity editor it has no problems and the nodes are there etc. I was wondering if the tsection and the shape are somehow out of whack. Its interesting because I have used these sections for several years up until now with no problems. I suppose I could use routeriter to give me locations and delete them then rebuild but would prefer to see if there is a simpler solution.
Hope this helps

#4 Bananarama

Bananarama

    The Big Kahuna

  • 3DTrains Admin
  • 8,090 posts

Posted 03 July 2011 - 10:48 AM

I checked and the entry appears to be a-OK, and if it weren't, many other routes, including the Feather River would cease to function. I suspect there's an issue with your route's tdb, and is likely due for a rebuild.

Cheers!
Marc

#5 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 03 July 2011 - 12:24 PM

QUOTE(Hack @ Jul 3 2011, 10:29 AM) View Post

I checked and the entry appears to be a-OK, and if it weren't, many other routes, including the Feather River would cease to function. I suspect there's an issue with your route's tdb, and is likely due for a rebuild.

Cheers!
Marc


Which is part of the problem it crashes during a rebuild. I will try redownloading see what happens.


#6 Bananarama

Bananarama

    The Big Kahuna

  • 3DTrains Admin
  • 8,090 posts

Posted 03 July 2011 - 02:11 PM

Remove those entries from the world files and try the rebuild from there.

Cheers!
Marc

#7 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 03 July 2011 - 04:58 PM

QUOTE(Hack @ Jul 3 2011, 1:52 PM) View Post

Remove those entries from the world files and try the rebuild from there.

Cheers!
Marc



Yeah, msts is a "funny" program, I was hoping to avoid that tho.

#8 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 04 July 2011 - 12:23 PM

I removed the Dmy sections and the rebuild worked fine. Kind of a shame as I like those sections. Its also odd that they worked for years with no problems, then even after another dload they would cause a crash. I had done a rebuild just before I had to reformat and that backup would not work. No big deal tho. If you ever figure it out let me know but its not a huge deal at all.

#9 Bananarama

Bananarama

    The Big Kahuna

  • 3DTrains Admin
  • 8,090 posts

Posted 05 July 2011 - 11:20 AM

I believe the reason they fail in a rebuild is that there's no track added to the diverging point. Now that I think of it, the times I rebuilt some of my routes I needed to "unlink" the dummy turnouts before a TDB rebuild. Once the build is complete, they can be added back in.

Cheers!
Marc

#10 mdeming

mdeming

    Stationmaster

  • Valued Customer
  • PipPipPip
  • 106 posts

Posted 05 July 2011 - 04:50 PM

QUOTE(Hack @ Jul 5 2011, 11:01 AM) View Post

I believe the reason they fail in a rebuild is that there's no track added to the diverging point. Now that I think of it, the times I rebuilt some of my routes I needed to "unlink" the dummy turnouts before a TDB rebuild. Once the build is complete, they can be added back in.

Cheers!
Marc



On double track its no issue at all, just add a crossover. On single track, well there are always abandoned sidings. Thanks for your time tho.
Mike